• Shuffle
    Toggle On
    Toggle Off
  • Alphabetize
    Toggle On
    Toggle Off
  • Front First
    Toggle On
    Toggle Off
  • Both Sides
    Toggle On
    Toggle Off
  • Read
    Toggle On
    Toggle Off
Reading...
Front

Card Range To Study

through

image

Play button

image

Play button

image

Progress

1/108

Click to flip

Use LEFT and RIGHT arrow keys to navigate between flashcards;

Use UP and DOWN arrow keys to flip the card;

H to show hint;

A reads text to speech;

108 Cards in this Set

  • Front
  • Back
  • 3rd side (hint)

Set name for Cisco device

(config) #hostname

Context-sensitive help for all commands available

Question mark (?)

List all first parameter options for command



?

Lists commands that start with com

com?

List all parameters beginning with parameter typed so far

command parm?

Complete command typed so far

[TAB]

Lists all parameters with a brief explanation

command parameter ?

2 keyboard shortcuts that show the previous command

1) up arrow


2) Ctrl+P

2 keyboard shortcuts that move forward through previous commands

1) down arrow


2) Ctrl+N

2 keyboard shortcuts that moves cursor backward along command

1) left arrow


2) Ctrl+B

2 keyboard shortcuts that moves cursor foward along command

1) right arrow


2) Ctrl+F

Keyboard shortcut that moves the cursor backward along command, deleting characters

Backspace

Turn on logging of ARP details

#debug arp

Display information about directly connected Cisco devices

#show cdp neighbors

Display list of physical ethernet addresses that have been discovered on a switch or router

>show mac address-table

Administratively disable an interface

(config-if) #shutdown

Keyboard shortcut to drop back to enable mode from any other sub-mode

Ctrl-Z

Reboot a Cisco network device

#reload

Erase all VLAN data from device

#delete flash:vlan.dat

Set domain name

(config) #ip domain-name <name>

Set console password


(2 commands)

(config-line) #password <password>


(config-line) #login

Set Level 7 encryption on all device passwords

(config) #service password-encryption

Append commands to a new line; switch information will not be interrupted.

(config-line) #logging synchronous

Turn off Domain Name System (DNS) queries so that spelling mistakes do not slow you down.


(config) #no ip domain-lookup

Create a private key for use with ssh

(config) #crypto key generate rsa

Move to a mode where you can edit ports 1-12 all at once

(config) #interface range fa0/1-12

Delete all dynamically-learned ethernet addresses from a switch's CAM table

#clear mac address-table dynamic


OR


#clear mac-address-table dynamic

Show all directly connected Cisco devices

#show cdp neighbors

Configure Cisco device for ssh access


(three commands)

(config)#ip domain-name


(config)#crypto key generate rsa


(config)#username secret >

check sequence of commands for dependency, also check accuracy of username command

Disable timeout for console connection

(config-line)#no exec-timeout

Use local user database for virtual terminal login information

(config-line)#login local

Set virtual terminal sessions to idle for 60 minutes before closing connection

(config-line)#exec-timeout 60

Set virtual terminal to allow both telnet and ssh

(config-line)#transport input telnet ssh

Set interface to full duplex at 100 Mbps


(two commands)

(config-if)#duplex full


(config-if)#speed 100

Configure switchport to permit two MAC addresses

(config-if)#switchport port-security maximum 2

Configure switchport to permit only the first learned MAC address(es) on a port

(config-if)#switchport port-security mac-address sticky

Display brief information only about FastEthernet port 1 on a switch

#show run interface fastEthernet 0/1

Display port security information about FastEthernet port 1 on a switch

#show port-security interface fastEthernet 0/1

Enable port security on a switch interface

(config-if)#switchport port-security

Display detailed information only about FastEthernet port 1 on a switch

#show interfaces fastEthernet 0/1

Enable DTP on a switchport

(config-if)#switchport mode dynamic

Hard-code a switchport as with 802.1Q


(two commands)

(config-if)#switchport trunk encapsulation dot1q


(config-if)#switchport mode trunk

check sequence of these commands to make sure they aren't dependent

Turn off DTP on switchport

(config-if)#switchport nonegotiate

Set trunk port to receive frames without 802.1Q tags on VLAN 5

(config-if)#switchport trunk native vlan 5

Display information about VTP on switch

#show vtp status

Disable VTP on switch

(config)#vtp mode transparent

Set VTP domain name

(config)#vtp domain <name>

Set VTP to run version 2

(config)#vtp version 2

Display VLAN information on a switch

#show vlan

Create VLAN 2 and name it ACCT


(two commands)

(config)#vlan 2


(config-vlan)#name ACCT


Put multiple switchports in VLAN 2


(2 commands)

(config-if-range)#switchport mode access


(config-if-range)#switchport access vlan 2

Display detailed VLAN information for fa0/2

#show interfaces fa0/2 switchport

2 ways of resetting Cisco device to factory default configuration


(two commands)

#write erase


#erase startup-config

Display verbose VLAN information for fastEthernet port 5

#show interfaces fastEthernet 0/5 switchport

Configure trunk port to only permit VLANs 2 & 3

(config-if)#switchport trunk allowed vlan 2-3

Erase statistics on FastEthernet port 1

#clear counters fastEthernet 0/1

check that this command doesn't need interface

Display list and information about IP addresses and routes on a router

#show ip route

Create a default route where 192.168.0.1 is the IP of the forwarding router.

(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.1

Allow subnets with all zeros

(config)#ip subnet-zero

In ROMMON, tell IOS to boot while ignoring NVRAM

rommon>confreg 0x2142

In ROMMON, tell devices to powercycle

rommon > reset


Re-enable NVRAM on reboot

(config)#config-register 0x2102

"Impersonate" an ISP and set the speed

(config)#clock rate <#####>

Log user off
(2 ways of doing it)

>exit


OR


#logout


Enter startup mode

#setup


Disable keyboard shortcuts

#terminal no editing


Set command-line output to display the default number of lines

#terminal length 24


Set number of commands in the buffer to the maximum size

#terminal history size 256


Display information about Cisco IOS software

#show version


List all commands in the history buffer

#show history


Display information about flash memory

#show flash


Leave privileged mode

#disable


Display information about the Ethernet controller

#show controllers


Display current configuration in DRAM

#show running-config


Display current configuration in NVRAM

#show startup-config


Determine whether the switch passed POST

#show post


Move to global configuration mode

#configure terminal


Set enable password to cisco

(config)#enable password cisco


Set encrypted password to class

(config)#enable secret class


Assign management IP to default VLAN


(two commands)

(config)#interface vlan1


(config-if)#ip address 192.168.0.1 255.255.255.0


Set default gateway on switch

(config)#ip default-gateway 192.168.0.1


Require user to login to console before use

(config-line)# login

Prevent console line from logging out when the connection is idle

(config-line)# exec-timeout 0 0

Create EIGRP routing for autonomous system 10

(config)# router eigrp 10


Advertise directly connected networks (classful address only)

(config-router)# network A.B.C.D


Disable automatic summarization

(config-router)# no auto-summary


Create virtual subinterface on router

(config-if)# interface fastethernet 0/0.1

Double check mode on this flash card

Assign trunking protocol to subinterface, VLAN 1 - the native vlan

(config-subif)# encapsulation dot1q 1 native


Set switch to VTP Server mode for VLANS

(config)# vtp mode server


Enable IP routing on switch

(config)# ip routing

Create a Layer 3 port on a switch

(config-if)# no switchport

Change switch to VTP client mode

(config)# vtp mode client

Display output including fields:


OK? ...and... Method

# show ip interface brief


View usability status of IP interfaces

# show ip interface

Configure protected ports (private VLAN edge ports) on a Cisco Catalyst 2950 switch

(config-if)# switchport protected

Menu-based prompt for testing ICMP connections

> ping ....OR...


# ping

Prevent DHCP allocation of the IP 10.1.0.253

(config)# ip dhcp excluded-address 10.1.0.253

View information about the DHCP address pool

# show ip dhcp pool

Disable CDP on a single interface

(config-if)# no cdp enable

Disable CDP on an entire router

(config)# no cdp run

Configure port security to shut down port if more than one physical address is detected


(2 commands)

(config-if)# switchport port-security maximum 1


(config-if)# switchport port-security violation shutdown

Discover routes a packet takes to destination address

> traceroute

Equivalent of tracert used in Windows OS

Disable sending routing updates on a router interface

(config-router)# passive-interface

Prevents RIP routes

Configure a router to use DNS for hostname resolution

(config)# ip domain lookup


Define static hostname-to-address mappings on router

(config)# ip host

If hostname cache does not exist yet, it is automatically created

Display information about the interfaces on which CDP is enabled

# show cdp interface

Enables a router to forward packets destined for a subnet with no default route to best supernet possible

(config)# ip classless

Restrict incoming and outgoing connections between a particular VTY

(config-line)# access-class