Study your flashcards anywhere!

Download the official Cram app for free >

  • Shuffle
    Toggle On
    Toggle Off
  • Alphabetize
    Toggle On
    Toggle Off
  • Front First
    Toggle On
    Toggle Off
  • Both Sides
    Toggle On
    Toggle Off
  • Read
    Toggle On
    Toggle Off
Reading...
Front

How to study your flashcards.

Right/Left arrow keys: Navigate between flashcards.right arrow keyleft arrow key

Up/Down arrow keys: Flip the card between the front and back.down keyup key

H key: Show hint (3rd side).h key

A key: Read text to speech.a key

image

Play button

image

Play button

image

Progress

1/27

Click to flip

27 Cards in this Set

  • Front
  • Back
What's the best way to remember the 4 types of IP addresses used with NAT?
Inside always refers to an inside device whereas outside an outside device, local is loco, a crazily made up address, and global is good since routable on Internet. So a packet goes from the src of Inside Local to the dst of Outside Global.
List processes that happen between DHCP client and server when the client requests an IP address?
1. Client sends DHCPDISCOVER (UDP67) bcast to find DHCP server. 2. Server sends DHCPOFFER (UDP68) unicast offering ipconfig info (client typically selects first server that responds). 3. Client responds with DHCPREQUEST unicast confirming it wants the ipconfig offered. 4. Server sends DHCPACK bcast confirming ipconfig to everyone.
To create a pool of public IP addresses.
R1(config)# ip nat pool [name] [start IP] [end IP] [netwmask [subnet mask] | prefix-length [prefix-length]
To Static NAT between a specified internal (private) and external (public) IP address.
R1(config)# ip nat inside source static [original IP] [translated IP]
To Static NAT between a specified internal (private) and external (public) IP address and port number. This is useful in situations where you have a single public IP address and need to use it for accessing two or more internal servers from outside.
R1(config)#ip nat inside source static [protocol] [original IP] [port] [translated IP] [translated port]
To dynamically NAT between an ACL and an interface or Pool of addresses. Add "overload" keyword to PAT which allows multiple inside addresses to share a common outside address.
R1(config)#ip nat inside source list [access-list] [pool [name] | interface [type] [mod/num]] [overload]
To specify the maximum number of entries permitted in the NAT table. So max translations allowed at one time.
R1(config)# ip nat max-entries [number]
To identify an interface as an inside or outside NAT interface.
R1(config-if)# ip nat [inside | outside]
To see a table of NAT translations showing protocol the IP addresses for Inside Local, Inside Global, Outside Local, Outside Global.
R1# show ip nat translations
To remove all dynamic entries from a routers NAT translation table.
R1# clear ip nat translation *
To see which interfaces are NAT inside and outside interfaces, as well as statistics like number of dynamic & static translations, hits and misses.
R1# show ip nat statistics
To see what translations are happening in real-time. In the output s=src, d=dst and >=translated address.
R1# debug ip nat
To set the broadcast types that IP helper relays. By default includes TFTP, DNS, ITS, NetBIOS, BootP and TACACS.
R1(config)# ip forward-protocol udp [port number]
To configure a router as a relay agent, so relays bcasts received on that interface to the specified IP address.
R1(config-if)# ip helper-address [ip add]
To configure an interface to obtain its IP address via DHCP.
R1(config-if)# ip address dhcp
To specify a single or range of IP addresses not to be assigned to DHCP clients.
R1(config)# ip dhcp excluded-addresses [beginning IP] [ending IP]
To create a DHCP pool that is used to contain all the DHCP ipconfig info.
R1(config)# ip dhcp pool [name]
To specify the subnet of IP addresses that will be used by the DHCP pool to assign to clients.
R1(dhcp-config)# network [network address] [subnet mask]
To specify the IP address of the default gateway to be given to a DHCP client.
R1(dhcp-config)# default-router [IP address]
To specify the IP address of the DNS server to be given to a DHCP client.
R1(dhcp-config)# dns-server [IP address]
To specify the duration of a DHCP lease be given to a DHCP client.
R1(dhcp-config)# lease [days hours minutes]
To show any IP address conflicts a router identifies along with the method the router used to identify them (Ping or gratuitous ARP).
R1# show ip dhcp conflict
To clear all currently identified conflicts.
R1# clear ip dhcp conflict *
To show all the IP addresses the Cisco IOS DHCP server has assigned, along with there corresponding MAC addresses and lease expirations.
R1# show ip dhcp binding
To release all current DHCP bindings.
R1# clear ip dhcp binding *
To display real-time info about DHCP address assignment and database updates.
R1# debug ip dhcp server events
To show the DHCP packets being sent in real-time. Only shows packet type, IP address, MAC address and interface.
R1# debug ip dhcp server packets