Study your flashcards anywhere!

Download the official Cram app for free >

  • Shuffle
    Toggle On
    Toggle Off
  • Alphabetize
    Toggle On
    Toggle Off
  • Front First
    Toggle On
    Toggle Off
  • Both Sides
    Toggle On
    Toggle Off
  • Read
    Toggle On
    Toggle Off
Reading...
Front

How to study your flashcards.

Right/Left arrow keys: Navigate between flashcards.right arrow keyleft arrow key

Up/Down arrow keys: Flip the card between the front and back.down keyup key

H key: Show hint (3rd side).h key

A key: Read text to speech.a key

image

Play button

image

Play button

image

Progress

1/268

Click to flip

268 Cards in this Set

  • Front
  • Back
command to enable AAA
aaa new-model
What can happen when a port security is violated
shutdown; restrict; protect
Command to display MAC address table port-secuity info
show port-security address
command to apply a VLAN map named v-list to VLAN 23
vlan filter v-list vlan-list 23
Command to show queuing method on int fas 0/1
show queuing int f0/1
IP multicast address range: Limited Scope Addressing
239.0.0.0 to 239.255.255.255
IP multicast address range: Reserved Local Link
224.0.0.0 to 224.0.0.255
IP multicast address range: Globally Scoped Addresses
224.0.1.0 to 238.255.255.255
IP multicast address range: Source Specific Multicast/ Protocol Independent Multicast
232.0.0.0 to 232.255.255.255
IP multicast address range for GLOP (reserved or orgs that have AS number)
233.0.0.0 to 233.255.255.255
Command to enable multicast routing
ip multicast-routing
Command to enable PIM in sparse mode
ip pim sparse-mode
Command to show HSRP status
show standby
Command to enable HSRP on IF with redundant gateway IP of 172.16.2.3
standby ip 172.16.2.3
Command to enable multicast routing
ip multicast-routing
Command to enable PIM in sparse mode
ip pim sparse-mode
Command to show HSRP status
show standby
Command to enable HSRP on IF with redundant gateway IP of 172.16.2.3
standby ip 172.16.2.3
Default priority for HSRP router
100
2 queuing methods for Modular QoS CLI,
CBWFQ (class-based weighted fair queuing)
LLQ Low Latency Queuing
VRRP
virtual router redundancy protocol
Command to identify traffic in QoS CLI
class-map
NBAR
Network-Based Application Recognition
Command to enable uplink fast on a interface
spanning-tree uplinkfast
If an interface is in ON mode what does the adjacent switch interface need to be in to form etherchannel
ON
Command to change vtp domain name to cisco
vtp domain cisco
Command to make switch learn about vlans from vtp server
vtp mode client
Command to give vtp domain a password cisco
vtp password cisco
Your switch won’t have ports on neighboring switch vlan but wants to know about those vlans. Also wants to restrict broadcasts, multicasts and unknown unicasts so they won’t consume bandwidth on the trunks. Command to enable this
vtp pruning
Commands to enable trunking and encapsulation on an IF
switchport trunk encapsulation dot1q
switchport mode trunk
Commands to enable only one MAC address on IF
switchport mode access
switchport port-security
switchport port-security mac-address xx.xx.xx.xx.xx.xx
Command to ensure IF is not used to get to destination when there are multiple paths
spanning-tree cost 100
Command to force a switch to become the root switch
spanning-tree vlan 1 priority 4096 (or multiple of 4096)
Command to keep a link from becoming unidirectional due to cabling problem (on IF)
udld enable
Three types of ipv6 addresses
unicast (single sender to single sender)
anycast (packets sent to closest node in group)
multicast(single message to select group)
What types of EIGRP packets are sent unreliably?
ack; hello
What types of EIGRP packets are sent reliably?
update; query; reply
Default metric of IS-IS link
10
What is default OSPF network type on physical FR IF?
non-broadcast
What is default OSPF network type on Ethernet IF?
broadcast
What is default OSPF network type on FR point-to-point, HDLC and PPP IF?
point-to-point
command used to view RIP transactions
debug ip rip
command to show IS-IS neighbors
show clns neighbors
What is OSPF cost of 100 Mbps media
1
What is OSPF cost of 10 Mbps media
10
What is OSPF cost of 1000 Mbps (Gig-E) media
1
command to view OSPF IF information
show ip ospf interface
command to enable IS-IS routing on an IF
ip router isis
What protocols summarize automatically on classful boundaries?
EIGRP
RIP v1
RIP v2
IGRP
What type of LSAs are inter-area?
3 summary link advertisements – ABR origin, inter-area lsa
4 summary link advertisements – describe routes to ASBR, inter-area lsa
What type of LSAs are external?
5 AS-external – describes routes to other AS ; originates on ASBR
7 NSSA -- generated by NSSA ASBR
What type of routers can IS-IS Layer 2 routers be adjacent to?
Layer1/Layer2 router in same area
Layer 2 router in any area
What type of routers can IS-IS Layer 1 routers be adjacent to?
Layer 1 router in same area
Layer1/Layer2 router in same area
What OSPF network types elect a DR and BDR
broadcast
non-broadcast
What OSPF network types do not elect a DR and BDR?
point-to-point
point-to-multipoint
point-to multipoint non-broadcast
What type of OSPF area does not allow type 5 LSAs and cannot have an ASBR?
stub area
totally stubby area
NAT keyword that defines one to one translation
static
(ip nat inside source static X.X.X.X X.X.X.X)
command to show EIGRP neighbors
show ip eigrp neighbors
command to show successors and FD in EIGRP
show ip eigrp topology
BGP hold time
180 seconds
BGP keepalive time
60 seconds
BGP external TPC port
179
command for BGP enable on router
router bgp 65xx1
command for BGP network on neighbor router
neighbor xx.xx.xx.xx remote-as 65xx2
command for BGP to advertise a network connected to it
network x.x.x.x
command to configure a loopback IF on BGP router
int lo0
ip add X.X.X.X X.X.X.X
no shut
command to configure IBGP session on router from another routers’s loopback IF
router bgp 65xx1
neighbor x.x.x.x remote-as 65100 (the common AS)
neighbor x.x.x.x update-source loopback 0
(where x.x.x.x is the loopback IF of your own router)
Steps to influence path selection in BGP
1. define access-list
a. access-list 10 permit x.x.x.x 0.0.0.255
2. name the access list
a. router-map pref_change permit 10
3. tell it what to match
a. match ip address 10
4. give it a preference
a. set local-preference
5. identify the incoming address first by going into your own AS then defining the neighbor and telling your router how you want to restrict traffic
a. router bgp 651xx (your router)
b. neighbor x.x.x.x remote-as 652xx (neighbor router)
c. neighbor x.x.x.x router-map pref_change in (apply router map named pref_change to the incoming data on that IF)
commands to make sure your router passes EBGP routes to another router in your AS that your router is the next hop
router bgp 65100 (your AS)
neighbor 192.168.2.1 remote-as 65100 (also your AS)
neighbor 192.168.2.1 next hop self
commands to summarize routes on bgp router
router bgp 65100 (your AS)
aggregate-address 192.168.100.0 255.255.254.0 summary-only as-set
commands to put OSPF networks in backbone and area 23
router ospf 1
network 192.168.2.0 0.0.0.255 area 23
network 192.168.3.0 0.0.0.255 area 0
command to add a network to OSPF and make it stubby
router ospf 1
network 192.168.2.0 0.0.0.255 area 99
area 99 stub no-summary
command to hide hosts on a NAT inside IF
access-list 10 permit 192.168.2.0 0.0.0.255 (network you want to hide)
ip nat inside source list 10 interface s0 overload (applies access-list to IF)
int e/0#> ip nat inside
int s/0#> ip nat outside
enable EIGRP on both router IFs
router eigrp 23
network 192.168.2.0
network 192.168.100.0
commands to configure autos summary of 10.12.0.0 – 10.16.0.0 on Serial 0
interface s0
ip summary-address eigrp 45 10.12.0.0 255.252.0.0 5 (admin distance of 5)
command to show IS-IS neighbors
show clns neighbor
command to apply outbout prefix-list named pre_list to bgp peer 192.168.23.23
neighbor 192.168.23.23 prefix-list pre_list out
BGP port used to create and maintain connections
179
command to show adjacent routers
show ip ospf neighbors
default EIGRP hello interval and hold time
5 and 15 seconds
default EIGRP low-speed NBMA media hello interval and hold time
60 and 180 seconds
IS-IS valid hello packet types
LAN
point-to-point
command to advertise 172.16.24.0 – 172.16.31.0 out of area 0
area 0 range 172.16.24.0 255.255.248.0
what is the administrative distance of EIGRP
90
What is the administrative distance of OSPF
110
What is the administrative distance of RIP
120
What does sh ip mroute prepend the display with for a shared path tree
*
What does sh ip mroute prepend the display with for a source route or shortest path tree
S, G
command to ensure that egress traffic in the native vlan is tagged
set dot1q-all-tagged enable
GLBP
Gateway Load Balancing Protocol (load balancing over multiple routers with virtual ip address and multiple virtual MAC addresses)
What is used to tunnel IPv6 inside IPv4
IPv4-mapped IPv6
Convert this: 00-ac-00-4f-2b-5c to a Local link address
FE80::02AC:FF:FE4F:2B5C
What do you append the last 23 bits of an IP address to find the MAC address
01:00:5E
command to verify spanning tree is configured on a Cat-OS switch
show spantree summary
command to show current state of spanning tree for one vlan
show spantree vlan_id
command to show spanning tree statistics
show spantree statistics
command to show if backbonefast is configured
show spantree backbonefast
command to show spanning tree state of Token Ring port
show spantree portstate
command to show path cost for VLANS on a port
show spantree portvlancost
command to show path cost for VLANS on a port
show spantree portvlancost
command to show uplinkfast settings
show spantree uplinkfast
Name three tables created by OSPF process.
link state database; neighbor table; routing table
Port ON Off Auto Desirable Non-negotiate
On Y N Y Y Y
Off N N N N N
Auto Y N N Y N
Desirable Y N Y Y Y
Non-negotiate Y N N Y Y
Port ON Off Auto Desirable Non-negotiate
On Y N Y Y Y
Off N N N N N
Auto Y N N Y N
Desirable Y N Y Y Y
Non-negotiate Y N N Y Y
With what modes will a trunk be formed in ISL or 802.1q if the trunk is set in Desirable?
trunk
desirable
auto
With what modes will a trunk be formed in ISL or 802.1q if the trunk is set in Auto?
trunk
desireable
With what modes will a trunk be formed in ISL or 802.1q if the trunk is set in trunk?
desireable
auto
Default port STP port priority
128
STP port cost 10/100; 100; 1000 Mbps
19;19;4
Type 1 LSAs deal with :
routers in an area
generated by routers in an area
contain router id
contain connected networks
Type 2 LSAs deal with :
network in an area
scope is the originating area
generated by any router in area
contain network address
contain connected routers
Type 3 LSAs deal with :
summary info for inter-area routes
scope includes backbone and non-backbone that have no stubbiness
generated by ABRs
contain inter-area router info
Type 4 LSAs deal with
ABRouters
scope includes backbone and non-backbone than don’t have stubbiness
generated by ABRs
contain route to ABR
(maybe mistake ASBRs check this)
Type 5 LSAs deal with:
external routes
scope is the routing domain except for stubby and totally stubby areas
generated by ASBRs
contain route info outside the routing domain
Type 7 LSAs deal with:
Not So Stubby Areas
scope is the originating area
generated by ASBRs with NSSAs and converted to type 5 LSAs by the NSSA ABR with highest router ID
contain info about routes outside the routing domain
Which queuing methods do not adjust themselves to traffic load?
Custom queuing (CQ)
Priority queuing (PQ)
Which queuing methods adjust to traffic load?
CBWFQ and
WFQ
What are valid frame identifications methods on Cisco switches?
LANE
ISL
802.10
802.1Q
What does next hop 0.0.0.0 in “show ip bgp” command
route announced using aggreagate-address
route learned locally via redistributed IGP
What queuing method drops packets based on IP precedence?
WRED
What type of queuing gives priority to low bandwidth traffic?
WFQ
BGP routing decision matrix.
1.Next hop unreachable
2.Weight 3.Highest local pref 4.Routes originated on this router 5.Shortest AS path
6.Interior Origin 7.Lowest MED 8.Prefer external over internal sources 9.Closest IGP neighbor 10.Lowest originating router ID
What are the six states of HSRP
1 2 3 4 5 6
Initial Learn Listen Speak Standby Active
What happens in the initial state of HSRP?
nothing
HSRP not running
What happens in the learn state of HSRP?
waiting to hear from active router
no virtual IP determined
no hello recognized
What happens in the listen state of HSRP?
knows virtual IP
is neither active or standby
listening for hellos
What happens in the speak state of HSRP?
sends periodic hellos
participating in election of active or standby router
What happens in the standby state of HSRP?
candidate to become active
sends periodic hellos
only one router in standby state
What is EIGRP formula to calculate metric?
(10000000/bw) * 256 – bw is the lowest bw in the path
simplified to: metric = bandwidth + delay
How does EIGRP define a successor.
If reported distance is less that feasible distance
and has lowest cost path to destination
What are the three define attributes of BGP communities?
no-export do not advertise through eBGP
no-advertise do not advertise to any peer
internet: advertise to all
What are three characteristics of a BGP community?
not restricted to one AS
involved in redistribution
filters traffic in and out
What RFC for BGPv4
1771
What RFC for ICMP (router discover protocol IRDP)
1256
What RFC for VRRP (virtual router redundancy protocol)
2338
What does EIGRP use as a metric?
bandwidth, reliability, delay, loading, MTU
command to show if spanning tree is correctly configured on Cat OS
show spantree summary
What type of area restricts propagation of type 3LSAs and routers within the area are only aware of ABR addresses and do not know what type of ABR provides the best path?
Totally stubby area
What are the three different op codes for HSRP routers?
hello, resign and coup
What are the five well known community attributes of BGP?
Local-as : confederations; prevents sending packets outside the local as
No export : don’t advertise routes to external BGP peers
No-advertise : don’t advertise this route anywhere
None : apply no community attribute
Internet : advertise to the any router in the internet community
External BGP administrative distance
20
EIGRP administrative distance Internal route
90
Administrative distance OSPF route
110
administrative distance Internal BGP
200
Multicast address for all OSPF routers
224.0.0.5
Multicast address for all RIPV2
224.0.0.9
Multicast address for all OSPF designated routers
224.0.0.6
Multicast address for all EIGRP routers
224.0.0.10
IP protocol number for EIGRP
88
IP protocol number for IGRP
9
IP protocol number for OSPF
89
commands to configure access list on S0 for nat
access-list 1 permit 192.168.x.0 ip nat inside source list 1 interface serial 0 overload
commands to configure e0 and s0 as inside and outside nat interfaces
interface e0 / ip nat inside -- interface s0 / ip nat outside
command to summarize 172.16.0.4 on e0
(rip)
ip summary-address rip 172.16.0.0 255.255.252.0
command to encrypt all passwords
service password-encrypt
command to show the link state database of IS-IS
show IS-IS database
What device best controls broadcasts
router
What are the two primary functions of a router
path determination; packet switching
What is 802.1w RSTP
faster version of 802.1d (STP)
What are the five port types of RSTP
backup, alternate, root, disabled, designated
What two parameters are sent with VTP
revision number and management domain
What three attributes of hello packets do IS-IS routers sharing a common link need to become neighbors?
matching MTUs, matching IS types and clear passwords (if authentication is enabled)
What are two advantages of VTP2 over VTP1
support for token ring, consistency checking
How much encapsulation data added to a frame by ISL
30 Bytes
Type 1 LSA is what type of entry
router link
What protocol can drop packets based on IP precedence
WRED
Do hello and hold time need to match for EIGRP neighbors to form
no
What values have to match for EIGRP to form neighbor relationships
AS and K- values must match
How long does it take a port to go from blocking to forwarding states during STP calclulation
50 seconds
What switching method does not need the first packet sent to the route processor
Distributed Switching
A rendezvous point is needed for what types of modes
pim sparse-mode; pim sparse-dense-mode
What queuing method allows for percentages of available bandwidth for each queue
custom queuing
RFC # for ICMP (IRDP)
RFC 1256
RFC # for BGPv4
RFC 1771
RFC # for VRRP (Virtual Router Redundancy Protocol)
RFC 2338
command to encrypt all passwords?
service password-encrypt
command to show the link state database of IS-IS?
show IS-IS database
What device best controls broadcasts?
router
What are the two primary functions of a router?
path determination; packet switching
What is 802.1w RSTP?
faster version of 802.1d (STP)
What are the five port types of RSTP?
backup, alternate, root, disabled, designated
What two parameters are sent with VTP?
revision number and management domain
What three attributes of hello packets do IS-IS routers sharing a common link need to become neighbors?
matching MTUs, IS types and clear passwords (if authentication is enabled)
What are two advantages of VTP2 over VTP1?
support for token ring, consistency checking
How much encapsulation data added to a frame by ISL?
30 Bytes
Type 1 LSA is what type of entry?
router link
What protocol can drop packets based on IP precedence?
WRED
Do hello and hold time need to match for EIGRP neighbors to form?
no
What values have to match for EIGRP to form neighbor relationships?
AS and K- values must match
How long does it take a port to go from blocking to forwarding states during STP calclulation?
50 seconds
What switching method does not need the first packet sent to the route processor?
Distributed Switching
A rendezvous point is needed for what types of modes?
pim sparse-mode; pim sparse-dense-mode
What queuing method allows for percentages of available bandwidth for each queue?
custom queuing
RFC # for ICMP (IRDP)?
RFC 1256
RFC # for BGPv4?
RFC 1771
RFC # for VRRP (Virtual Router Redundancy Protocol)?
RFC 2338
Name four features of IS-IS?
Fast convergence; rapid flooding of new informaiton; hierarchical; classless
What four conditions have to be met for two Level 1 routers to form and adjacency?
Must have: matching passwords; be in same area; configured to use the correct Hello type; have physical link
What are used by IS-IS to request a LSP (Link State Packet)?
PSNP Partial Sequence Packet Number
Command to prevent helper address from forwarding DHCP requests?
no ip forward-protocol udp 67 and no ip forward-protocol 68
Command to make area 10 stubby?
Area 10 stub
Command to make area 10 totally stubby?
Area 10 stub no-summary
Command to make area 10 not so stubby?
Area 10 nssa
Command to show current OSPF entries in routing table?
show ip router ospf
Command to debug EIGRP adjacency formation?
debug eigrp neighbor
When receiving an update from an external BGP speaker, where will a route reflector advertise the update?
to all BGP routers withing the AS
When receiving an update from an a non-client peer where will a route reflector advertise the update?
to all clients
When receiving an update from a client, where will a route reflector advertise the update?
to all clients and non-client peers
What is the IEEE standard for traffic prioritization?
802.1p
What is the IEEE standard for VLANs?
802.1Q
What is the IEEE standard for Ehternet?
802.3
What is the IEEE standard for Fast Ethernet?
802.3u
What is the IEEE standard for Gigabit Ethernet?
802.3z
What type of PIM mode is best for scattered, intermittant traffic with few receivers and they are separated by WAN links?
Sparse mode
What type of PIM mode works with heavy, sustained traffic flow with many receivers and there is close proximity?
What are the eight levels of IP precedence?
0 routine; 1 priority; 2 immediate; 3 flash; 4 flash-override; 5 critical; 6 internet; 7 network
What is the highest level of precedence you can assign? 5 critical
5 critical
What are the valid RSTP port states?
learning; forwarding; discarding
What is SLB?
Server Load Balancing. Allows multiple private devices to share one public IP with NAT.
In ISL or 802.1q Desireable state will form trunks with what states?
trunk; desirable; auto
In ISL or 802.1q auto state will form trunks with what states?
trunk;desireable
In ISL or 802.1q Nonegotiate will form trunks with what states?
You must manually configure it.
What is the period of time required to take frame bits and transmit them onto the physical media?
Serialization Delay
What is the period of time required to process upper layer information and encode the data into Layer 3 packets?
Packetization Delay
What is the period of time required for bits to cross the physical media?
Propagation Delay
What is the period of time a packet is held in an output queue before transmission?
Queuing Delay
What is the period of time from when a networking device receives a packet on an input interace, transitions it to the receive queue and processes it to the ouput queue?
CPU Latency Delay (not a type of network delay)
Name four features of IS-IS?
Fast convergence; rapid flooding of new informaiton; hierarchical; classless
What four conditions have to be met for two Level 1 routers to form and adjacency?
Must have: matching passwords; be in same area; configured to use the correct Hellow type; have physical link
What are used by IS-IS to request a LSP (Link State Packet)?
PSNP Partial Sequence Packet Number
Command to prevent helper address from forwarding DHCP requests?
no ip forward-protocol udp 67 and no ip forward-protocol 68
Command to make area 10 stubby?
Area 10 stub
Command to make area 10 totally stubby?
Area 10 stub no-summary
Command to make area 10 not so stubby?
Area 10 nssa
Command to show current OSPF entries in routing table?
show ip router ospf
Command to debug EIGRP adjacency formation?
debug eigrp neighbor
When receiving an update from an external BGP speaker, where will a route reflector advertise the update?
to all BGP routers withing the AS
When receiving an update from an a non-client peer where will a route reflector advertise the update?
to all clients
When receiving an update from a client, where will a route reflector advertise the update?
to all clients and no-client peers
What is the IEEE standard for VLANs?
802.1Q
What is the IEEE standard for Ehternet?
802.3
What is the IEEE standard for Fast Ethernet?
802.3u
What is the IEEE standard for Gigabit Ethernet?
802.3z
What type of PIM mode is best for scattered, intermittant traffic with few receivers and they are separated by WAN links?
Sparse mode
What type of PIM mode works with heavy, sustained traffic flow with many receivers and there is close proximity?
What are the eight levels of IP precedence?
0 routine; 1 priority; 2 immediate; 3 flash; 4 flash-override; 5 critical; 6 internet; 7 network
What is the highest level of precedence you can assign? 5 critical
What are the valid RSTP port states?
learning; forwarding; discarding
What is SLB?
Server Load Balancing. Allows multiple private devices to share one public IP with NAT.
In ISL or 802.1q Desireable state will form trunks with what states?
trunk; desirable; auto
In ISL or 802.1q auto state will form trunks with what states?
trunk;desireable
In ISL or 802.1q Nonegotiate will form trunks with what states?
You must manually configure it.
What is the period of time required to take frame bits and transmit them onto the physical media?
Serialization Delay
What is the period of time required to process upper layer information and encode the data into Layer 3 packets?
Packetization Delay
What is the period of time required for bits to cross the physical media?
Propagation Delay
What is the period of time a packet is held in an output queue before transmission?
Queuing Delay
What is the period of time from when a networking device receives a packet on an input interace, transitions it to the receive queue and processes it to the ouput queue?
CPU Latency Delay (not a type of network delay)
What is the command to put faste 0/4 into a non trunking mode in vlan 2
int faste 0/4; siwtchport mode access; switchport access vlan 2
What is the command to make fae0/24 always be a trunk and have 802.1q encapsulation?
Iint faste 0/24; switchport trunk encapsulation dot1q; switchport mode trunk
What is the command to make interface f0/23 and f0/24 look like one link to spanning tree?
int f0/23; channel-group 1 mode on; repeat for f0/24
What is the command to make VLAN 2000.
vtp mode transparent; vlan 2000
What is the command to make fa0/23 a trunk using isl encapsulation?
int fa0/23; switchport trunk encapsulation isl
What is the command to protect a portfast port if a switch is accidentally plugged into it?
spanning-tree bpduguard enable
What is the command to keep a switchport out of spanning-tree if a switch is accidentally plugged into it?
spanning-tree bpdufileter enable
Command to ensure only one Mac Address is allowed in a port.
int fa 0/x; switchport mode access; switchport port-security; switchport port-security mac-address 0010.7be8.85fc
Command to attach network analyzer to port fa0/3 to monitor fa0/4.
monitor sesson 1 source interface fa 0/2; monitor session 1 destination interface fa0/3
Command to make switch choose fa0/24 over fa0/24.
int faste 0/23; spanning-tree cost 100
Command to make vlan 1 spanning tree root
config)#spanning-tree vlan 1 priority 4096
Command to enable IS-IS on and interface.
ip router isis