• Shuffle
    Toggle On
    Toggle Off
  • Alphabetize
    Toggle On
    Toggle Off
  • Front First
    Toggle On
    Toggle Off
  • Both Sides
    Toggle On
    Toggle Off
  • Read
    Toggle On
    Toggle Off
Reading...
Front

Card Range To Study

through

image

Play button

image

Play button

image

Progress

1/18

Click to flip

Use LEFT and RIGHT arrow keys to navigate between flashcards;

Use UP and DOWN arrow keys to flip the card;

H to show hint;

A reads text to speech;

18 Cards in this Set

  • Front
  • Back

VLAN

Virtual Local Area Network

A broadcast domain created on a switch which also coordinates to a TCP/IP subnet

VTP

VLAN Trunking Protocol

Assists in the creation of VLAN's, must be connected with special interswitch links called trunks.


VTP Operating Mode

Server: Default




Transparent: Disables VTP




Client: Allows switches to inherit the VLAN information from a server(s). Cannot create VLAN's locally on a VTP Client device





show vlan (brief)



Useful for verifying VLAN's

default vlan

VLAN 1 is the default VLAN on Cisco switches and all non-trunk ports are listed as participants of this VLAN, it is a best practice to remove all ports from this default VLAN.

Typically, a special unused VLAN is created for any ports they aren't using on the switch




While by default two hosts connected to the same switch will be in separate collisions domains, both will be part of the same layer 2 broadcast domain and VLAN

switchport cmd.

used to assign ports to a VLAN




interface gi0/1


switchport mode access


switchport access vlan 20


end



Voice VLAN config

vlan 30


name WEST


vlan 50


name VOICE


exit


interface gi0/2


switchport mode access


switchport access vlan 30


switchport voice vlan 50


end




note that Cisco Discovery Protocol (CDP) is required for IP phones to function, but CDP is often enabled by default

show interface gi0/1 switchport

A powerful command displaying information regarding the interface configuration, including the Voice VLAN

Trunking

A normal port (access port) may only be assigned one VLAN at at time.




A trunk port may support multiple VLAN's, a port connecting one switch to another would be configured as a trunk

ISL

Inter Switch Link, older method used by Cisco to move traffic of different VLAN's from switch to switch




Encapsulated entire frame in order to add a VLAN marking



802.1Q trunk link

Most common ethernet trunking protocol in use today




Used to move traffic of different VLAN's from switch to switch. Injects a tag value into an existing frame, between the source MAC address and type fields of the frame header, which allows multiple VLAN's to be supported over a single trunk interface

TPID

Tag protocol identifier




a 16-bit field set to a value of 0x8100 in order to identify the frame as an IEEE 802.1Q-tagged frame

TCI

Tag control information, consists of the following




-Priority Code Point (PCP): A three-bit field that refers to the IEEE 802.1p class of service and maps to the frame priority level




-Drop eligible indicator (DEI): A one-bit field that may be used in conjuction with PCP to indicate frames eligible to be dropped in the presence of congestion




VLAN identifier (VID): A 12-bit field specifying the VLAN to which the frame belongs

Configuring 802.1Q trunking

interface gi1/0


switchport trunk encapsulation dot1q


(sets dot1q as the protocol)


switchport mode trunk
(activates trunking)


end

Native VLAN

The native VLAN is not tagged, the only untagged VLAN in the infrastructure, by default it is VLAN 1




Used for management traffic which will continue to flow between devices even if a link loses its trunking status.




CDP messages are sent over the Native LAN by default

CDP

Cisco Discovery Protocol, is a level 2 service which allows cisco devices to communicate information about each other to their directly connected neighbors




Useful when you are unsure of the topology




Used by cisco IP phones to communicate their capabilities and VLAN information to their local switch




CDP messages are not forwarded




enabled by default

CDP (contd.)

To ensure that CDP is active




configure terminal


cdp run (enables cdp globally)


interface gi1/0


cdp enable (enables cdp on interface)


end




though useful, CDP presents a potential security risk, it is often disabled on public facing interfaces

LLDP

Link Layer Discovery Protocol, is an open standard approach that serves the same basic purpose as CDP, thought it is not enabled by default of cisco switches. To activate;




configure terminal


lldp run


interface gi1\0


lldp transmit


lldp receive


end